智简魔方财务系统 / 安装配置

释放双眼,带上耳机,听听看~!

安装配置

一、环境要求

系统使用PHP+MYSQL开发,环境要求如下:

下表显示了运行魔方财务1.0.0及更高版本的最低和建议的系统要求。

需求最低要求推荐的*
操作系统Linux类UNIX
PHP版本7.2最新的 7.2或7.3版本
PHP内存限制64MB128MB
PHP数据库扩展PDOPDO
PHP扩展Curl with SSLGD2 库图像
支持JSON 
XML
GD2 库图像 
IMAPIconv
MBString
GMP
OpenSSL
BC Math 
MySQL版本5.6.0最新 5.6

注:数据库须使用MySQL 5.6.0,禁止使用Opcache

二、系统使用thinkphp框架开发,需设置伪静态

1.apache伪静态规则

<IfModule mod_rewrite.c>

  Options +FollowSymlinks -Multiviews

  RewriteEngine On

  RewriteCond %{REQUEST_FILENAME} !-d

  RewriteCond %{REQUEST_FILENAME} !-f

  RewriteRule ^(.*)$ api.php?s=$1 [QSA,PT,L]

  SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0

</IfModule>

2.nginx伪静态规则

location / {

if (!-e $request_filename) {

rewrite ^(.*)$ /api.php?s=$1 last;

break;

}

}

三、设置运行目录为/public

系统使用 Thinkphp 框架开发,要求将运行目录设置为public

四、访问 http:/域名/install 进行安装

Linux教程

InPanel : 一款免费开源的 Linux 服务器管理面板

2020-9-2 10:27:24

Linux教程

Centos7 绑定多网卡教程

2020-9-3 0:14:20

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索